局域网的组建和维护毕业设计

时间: 2020-11-06 09:07:20     来源: 论文范文网

摘 要

互联网的迅速的发展,已经影响了每个企业的对外交流方式,全世界的企业,都在用互联网技术,进行新的营销,销售,人们已经从传统的企业发展模式转移到互联网上面。

而我们要知道,每个企业的网络是一个单独的孤岛,要想每个企业能够互联互通,就需要进行数据的交换,数据交换和信息的交流,重点是要掌握组建局域网的知识,局域网对于我们大学生以后工作,学习,以及进入社会,都非常的有帮助。大学生作为世界的未来,更应该学会,接受,运用新技术和知识。

计算机知识的普及,也给现代社会的办公带来极大的便利和改革,办公自动化,企业oa,财务管理系统,认识管理系统等等,局域网络应用的成功不仅会对企业的现有业务产生巨大影响,更为企业日后的发展插上了腾飞的翅膀。本文以局域网络组建为例,叙述了局域网组建的具体做法和怎样进行维护的思想。


关键字:互联网,局域网,企业,组建设计




                      Abstract

The rapid development of the Internet, which has affected the foreign exchange of each enterprise, enterprises all over the world, in the use of Internet technology, marketing, sales, it has been from the traditional enterprise development pattern transferred to the Internet.

And we want to know, every enterprise network is a separate island and to each enterprise to interoperability, data exchange, data exchange and information communication, the focus is to master the knowledge of local area network to form the, LAN for our college students after work, learning, and enter the society, very help. College students as the future of the world, but should learn to accept, the use of new technology and knowledge.

The popularity of computer knowledge, to the office of the modern society bring great convenience and reform, office automation, enterprise OA, financial management system, knowledge management system, and so on, the success of local area network applications will not only to enterprise's existing business produced huge influence, more for the future development of enterprises in the wings. Taking the local area network as an example, this paper describes the specific practices of the local area network and the idea of how to maintain the local area network.

Key words: Internet; local area network; set up, design





目录

第1章 局域网概述 1

第2章 局域网设计分析 3

2.1 设计背景..................................3

2.2 用户需求分析...............................3

2.3 设计原则..................................5

第3章 局域网设计实现 7

3.1 网络体系结构.........................................7

3.2 网络层次划分.........................................8

3.3 网络设备选型.........................................8

3.4 设备端口划分........................................15

3.5 网络IP子网划分.....................................16

3.6  vlan的规划........................................18

3.7 以太网交换技术......................................23

第4章 局域网技术应用与网络配置.....................26

4.1 交换技术的应用......................................26

4.2 路由技术的应用....................................30

第5章 局域网的维护...................................37

5.1 软件系统............................................37


5.2 硬件系统............................................37

5.3 故障诊断............................................38

结束语...................................................39

谢词.....................................................39

参考文献.................................................39


第1章 局域网概述

局域网指在一段距离内很多电脑联合在一起组合而成的网络。局域网主要用途包括共享打印机、绘图机等外部设备,通过公共数据库共享各类信息,向用户提供诸如电子邮件之类的高级网络服务等。局域网是封闭的,可以是两台计算机也可以是上千台的计算机。

   局域网有共享文件、共享硬件、共享数据库、信息传递、保存信息、保护信息、Internet功能、远程访问功能等作用。

  局域网包括拓扑结构、传输介质和介质询问方式。

1.拓扑结构

局域网拓朴结构有星型结构、树型结构、总线型结构、和环形结构。

2.传输介质

  适用于局域网的介质主要有三类:双绞线、同轴电缆和光纤。

双绞线由两根具有绝缘保护层的铜导线组成。但价格较为低廉,干扰能力强,特别是非屏蔽双绞线。

同轴电缆以硬铜线为芯。它们的区别在于粗同轴电缆屏蔽更好,能传输更远的距离。

光纤分为:单模光纤的纤芯直径很小,在给定的工作波长上只能以单一模式传输,传输频带宽,传输容量大。

3.介质询问方式

局域网出现以后,发展迅速,类型繁多。国际标准化组织(ISO)经过讨论。建议将802标准定为局域网估计标准。







第2章 局域网设计方案

2.1 设计背景

(1)按实际工作环境来约束所有条件。

(2)网络作为办公所依托的重要资源,为公司提供办公自动化、计算机管理、资源共享及信息交流等全方位的服务,目前公司有大约80个人,分为四个部门  

(3)综合布线工程已经完成,现在建设局域网部分  

(4)公司计划只使用172.16.43.0/24的一个网段(包括分公司)

(5)公司的财务数据是严格保密的:在路由器上使用NAT来完成

(6)B公司和公司有长期的业务来往,希望能和公司有通信的需求(能互发邮件即可)IP网段的使用。

(7)使用OSPF互通尽量使用多区域的OSPF),公网所有的网段只能使用202.96.7.192/26。

2.2 用户需求分析

总公司组织机构分为经理室、财务部、市场部、技术部,公司各部门经理向总经理负责,如下表:


4.1.1 vtp应用

VTP(VLAN Trunking Protocol):是VLAN中继协议,也被称为虚拟局域网干道协议。它是思科私有协议。从而减少在多台设备上配置同一个VLAN信息的工作量,而且保持了VLAN配置的统一性。

由于本次设计交换机数量较多,而各接入层交换机配置命令基本相同.为实现单个控制点配置和管理整个网络中VLAN,决定采用VTP

1.vtp的设计:

(1)VTP的域名为DLA。

(2)VTP版本为v2。

(3)VTP域口令为cisco。

(4)VTP修剪设为启用。

(5)VTP server包括dl-l3-1,dl-l3-2。

(6)VTP client包括da-l2-1~~5。

  其中采用修剪来减少vlan的广播数据流量的扩散,vtp口令保证了vtp域的安全以防止vlan被错误或恶意的增加删除.

2.vtp的主要配置

Dl-l3-1(config)#vlan 2 name dl-sc

Dl-l3-1(config)#vtp version 2

Dl-l3-1(config)#vtp domain dla

Dl-l3-1(config)#vtp pruning

Dl-l3-1(config)#vtp password cisco

Dl-l3-2的配置与Dl-l3-1类似。

4.1.2 stp应用

   STP(Spanning Tree Protocol)是生成树协议的英文缩写。The protocol can be applied to loop network, through a certain algorithm to achieve path redundancy. At the same time, the loop network pruning a tree network of loop free, thereby eliminating loops in the network, to avoid the broadcast storm problem due to the existence of the loop and. Spanning tree protocol suitable for all manufacturers of network equipment, in configuration and reflected intensity functions vary, but in principle and application effect is consistent. The principle of the agreement is in accordance with the tree structure to construct the network topology. The protocol using BPDU message transfer spanning tree information.     由于设计各交换网络采用环状的物理链路提供备份线路,而可能造成广播风暴的产生,决定采用STP,提高网络的可靠性和负载分担。

1.stp的设计

(1)Cisco交换机支持每个vlan的生成树(pvst),在本方案中我门也将采取这种方式,为每个vlan启用一个stp。

(2)交换机dl-l3-1为vlan2和4的根网桥。

(3)交换机dl-l3-2为vlan3和5的根网桥。

2.STP主要配置:

Dl-l3-1(config)#spanning-tree vlan 2 root primary

Dl-l3-1(config)#spanning-tree vlan 4 root primary

Dl-l3-2(config)#spanning-tree vlan 3 root primary

Dl-l3-2(config)#spanning-tree vlan 5 root primary

4.1.3 以太通道应用

   以太通道也称为以太端口捆绑、端口聚集或以太链路聚集. 以太通道为交换机提供了端口捆绑的技术,允许两个交换机之间通过两个或多个端口并行连接,同时传输数据,以提供更高的带宽.

   由于STP的应用,当存在2条物理链路时,虽然实现相互备份,却不能同时使用链路带宽,为提高链路带宽.决定在3层交换机上采用Ethernet Channel。

Ethernet chanel 配置命令:

Dl-l3-1(config)#interface range f0/23 -24

Dl-l3-1(config-range-if)#swichport mode trunk

Dl-l3-1(config-range-if)#channel-group 1 mode on

Dl-l3-2的配置与Dl-l3-1类似。

VLAN间路由

原本是通过单臂路由来实现vlan间的路由,但随着网络的庞大,在交换机上划分VLAN的数量不断增多,会使路由器和交换机之间的链路形成瓶颈,在单臂路由的一条物理链路已无法承载多条VLAN流量,同时占用链路带宽,决定采用三层交换技术实现数据包的高速转发和VLAN间路由.两台核心交换机各自为vlan设计管理ip,启用路由转发功能,此ip也是vlan内部pc的网关,使VLAN之间便于互相通信.

三层交换主要配置:

Dl-l3-1(config)#vlan 2

Dl-l3-1(config-vlan)#vlan 4

Dl-l3-1(config-vlan)#exit

Dl-l3-1(config)#interface range f0/1 -3

Dl-l3-1(config)#switchport access vlan 2

Dl-l3-1(config)#interface range f0/4 -5

Dl-l3-1(config)#switchport access vlan 4

Dl-l3-1(config)#interface f0/1

Dl-l3-1(config-if)#switchprot mode trunk

Dl-l3-1(config)#interface f0/0

Dl-l3-1(config-if)#no switchport

Dl-l3-1(config-if)#ip address 172.16.43.242 255.255.255.240

Dl-l3-1(config)#ip routing

Dl-l3-1(config)#interface vlan 1

Dl-l3-1(config-if)#ip address 172.16.43.225 255.255.255.192

Dl-l3-1(config)#interface vlan 2

Dl-l3-1(config-if)#ip address 172.16.43.1 255.255.255.192

Dl-l3-1(config)#interface vlan 3

Dl-l3-1(config-if)#ip address 172.16.43.65 255.255.255.192

Dl-l3-1(config)#interface vlan 4

Dl-l3-1(config-if)#ip address 172.16.43.129 255.255.255.224

Dl-l3-1(config)#interface vlan 5

Dl-l3-1(config-if)#ip address 172.16.43.161 255.255.255.224

Dl-l3-1(config)#ip route 0.0.0.0 0.0.0.0 172.16.43.241

Dl-l3-2的配置与Dl-l3-1类似。

4.2 路由技术的应用

   本次设计使用了OSPF路由协议,并且考虑到安全和冗余等因素,添加了VPN,ACL,HSRP等技术,符合了局域网的设计原则,加强了网络的可管理型,安全性与冗余。

4.2.1 OSPG区域规划

OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous system,AS)内决策路由。OSPF的协议管理距离(AD)是110。为了解决OSPF算法的频繁,路由表过大,路由链路状态数据库过大的问题划分了OSPF区域

1.具体划分原则:

(1)模拟ISP属于骨干区域0

(2)路由器ID的对照如表4-1。

表10 路由器ID对照

设备名称 LOOPback地址

Dl-l3-1 1.1.1.1

Dl-l3-2 2.2.2.2

Dl-r 3.3.3.3

B-r 4.4.4.4

Sy-r 5.5.5.5

2.OSPF的配置:

DL-R(config)#interface e0/0

DL-R(config-if)#ip address 202.96.7.193 255.255.255.252  

DL-R(config-if)#no sh

DL-R(config-if)#exit

DL-R(config)#router ospf 1

DL-R(config-route)#router-id 3.3.3.3

DL-R(config-route)#network 202.96.7.193 0.0.0.7 area 0

4.2.2 NAT的应用

网络地址转换简称nat,属接入广域网(WAN)技术,它的配置如下所示

Dl-l3-1(config)#vlan 2

Dl-l3-1(config-vlan)#vlan 4

Dl-l3-1(config-vlan)#exit

Dl-l3-1(config)#interface range f0/1 -3

Dl-l3-1(config)#switchport access vlan 2

Dl-l3-1(config)#interface range f0/4 -5

Dl-l3-1(config)#switchport access vlan 4

Dl-l3-1(config)#interface f0/1

Dl-l3-1(config-if)#switchprot mode trunk

Dl-l3-1(config)#interface f0/0

Dl-l3-1(config-if)#no switchport



由于A公司总部仅仅申请1个公有ip地址,为实现公司内部员工访问Internet,决定采用NAT技术,将私有的企业局域网透明地连接到公有网络

1.NAT的设计:

(1)公司申请了一条10M的光纤接入链路来接入因特网,以实现对因特网接入的高带宽,高速度的要求.分公司同样。

(2)总公司的外部IP地址202.96.7.193/29。  

(3)分公司的外部IP地址202.96.7.217/29。

(4)使用NAT的优点:节省公网IP,以ACL增加灵活性,安全性。

(5)在总公司和分公司的两台路由器上都启用复用内部LAN的地址。

2.NAT的配置命令:

DL-R(config)#interface e1/0

DL-R(config-if)#ip address 202.96.7.193 255.255.255.240

DL-R(config-if)#no sh

DL-R(config-if)#exit

DL-R(config)#access-list 101 deny 172.16.43.160 0.0.0.31

             172.16.43.109 0.0.0.15

DL-R(config)#access-list 101 permit any  any

DL-R(config)#ip nat inside source list 1 interface e1/0                          

             overload

DL-R(config)#interface f0/0

DL-R(config-if)#ip nat inside

DL-R(config)#interface e1/0

DL-R(config-if)#ip nat outside

沈阳分公司路由SY-r配置命令类似

4.2.3 VPN的应用

虚拟专用网络(Virtual Private Network ,简称VPN)指的是在公用网络上建立专用网络的技术。其之所以称为虚拟网,主要是因为整个VPN网络的任意两个节点之间的连接并没有传统专网所需的端到端的物理链路,而是架构在公用网络服务商所提供的网络平台,如Internet、Frame Relay等之上的逻辑网络,用户数据在逻辑链路中传输。

由于分公司经常与A公司总部进行财务数据汇总,而这些数据在互联网中的传递是及为不安全的,为实现数据的保密性及完整性,决定在两个公司之间搭建VPN隧道。在dl-r的e1/0和sy-r的e1/0上启用

1.架设VPN的优点:

(1)是架设在广域网上的虚拟专用网络。

(2)VPN只为特定的企业或群体所专用。

(3)费用低,不需要租用专线。

(4)结构灵活,可以灵活方便的增加或删除接点。

(5)使网络管理简单化。

(6)利用虚拟隧道技术提供网络连接使拓扑结构简单明。

2.VPN配置命令:

DL-R(config)#crypto isakmp policy 1

DL-R(config-isakmp)#authentication pre-share

DL-R(config-isakmp)#hash md5

DL-R(config-isakmp)#crypto isakmp key cisco address 202.96.7.217

DL-R(config)#access list 101 permit ip 202.96.7.193 0.0.0.15 202.96.7.217 0.0.0.15

DL-R(config)#crypto ipsec transform-set a ah-md5-hmac esp-des

DL-R(config)#crypto map a ipsec-isakmp

DL-R(config-crypto-map)#set peer 202.96.7.217

DL-R(config-crypto-map)#set transform-set a

DL-R(config)#interface e1/0

DL-R(config-if)#crypto map a

SY-R配置命令与DL-R类似

4.2.4 ACL的应用

访问控制列表(Access Control List,ACL) 是路由器和交换机接口的指令列表,用来控制端口进出的数据包。由于A公司总部及分公司财务数据是保密的,公司其他部门不能访问财务部,同时禁止财务部访问互联网,决定采用ACL,通过过滤数据包,提高网络的安全性

1.ACL的设计:

(1)禁止财务部访问Internet。

(2)禁止其他部门访问公司的财务电脑以及服务器。

(3)公司其他部门的员工可以正常访问Internet。

(4)分公司向总部报告财务数据。

(5)禁止分公司的员工访问Internet。

2.ACL的配置:

Dl-l3-1(config)#access list 101 deny ip 172.16.43.0 0.0.0.63 172.16.43.160 0.0.0.31

Dl-l3-1(config)#access list 101 permit any

Dl-l3-1(config)#interface vlan 2

Dl-l3-1(config-if)#ip access-group 101 in

Dl-l3-1(config)#access list 102 deny ip 172.16.43.64 0.0.0.63 172.16.43.160 0.0.0.31

Dl-l3-1(config)#access list 102 permit any

Dl-l3-1(config)#interface vlan 3

Dl-l3-1(config-if)#ip access-group 102 in

Dl-l3-1(config)#access list 103 permit any

Dl-l3-1(config)#interface vlan 4

Dl-l3-1(config)#ip access-group 103 in

Dl-l3-2配置命令类似

4.2.5 HSRP设计

HSRP:热备份路由器协议(HSRP:Hot Standby Router Protocol),是cisco平台一种特有的技术,是cisco的私有协议热备份路由器协议。HSRP的设计目标是支持特定情况下 IP 流量失败转移不会引起混乱、并允许主机使用单路由器,以及即使在实际第一跳路由器使用失败的情形下仍能维护路由器间的连通性。换句话说,当源主机不能动态知道第一跳路由器的 IP 地址时,HSRP 协议能够保护第一跳路由器不出故障。

由于配置STP,只能指定一台三层交换机的网关,当一台交换机出现故障时,主机无法切换网关,决定采用HSRP技术

1.HSRP的设计:

A公司在两台核心的三层交换机上启用热备份路由器协议(HSRP),其设计目标是支持特定情况下IP流量可以从故障设备切换到其他设备而不引起混乱,并允许主机使用单路由器作为网关,在实际第一跳路由器使用失败的情况下,仍能保持与网络的连通.

2.HSRP配置:

DL-L3-1:

Dl-l3-1(config)#interface vlan 2

Dl-l3-1(config-if)#standby 2 ip 172.16.43.3

Dl-l3-1(config)#standby 2 prioirly 200

Dl-l3-1(config)#standby 2 preempt

Dl-l3-1(config)#standby 2 track interface f0/0 80

Dl-l3-1(config)#interface vlan 4

Dl-l3-1(config-if)#standby 4 ip 172.16.43.131

Dl-l3-1(config)#standby 4 prioirly 200

Dl-l3-1(config)#standby 4 preempt

Dl-l3-1(config)#standby 4 track interface f0/0 80

Dl-l3-1(config)#interface vlan 3

Dl-l3-1(config-if)#standby 3 ip 172.16.43.67

Dl-l3-1(config)#standby 3 prioirly 150

Dl-l3-1(config)#standby 3 preempt

Dl-l3-1(config)#standby 3 track interface f0/0 80

Dl-l3-1(config)#interface vlan 5

Dl-l3-1(config-if)#standby 5 ip 172.16.43.163

Dl-l3-1(config)#standby 5 prioirly 150

Dl-l3-1(config)#standby 5 preempt

Dl-l3-1(config)#standby 5 track interface f0/0 80

DL-L3-2:

Dl-l3-2(config)#interface vlan 3

Dl-l3-2(config-if)#standby 3 ip 172.16.43.67

Dl-l3-2(config)#standby 3 prioirly 200

Dl-l3-2(config)#standby 3 preempt

Dl-l3-2(config)#standby 3 track interface f0/0 80

Dl-l3-2(config)#interface vlan 5

Dl-l3-2(config-if)#standby 5 ip 172.16.43.163

Dl-l3-2(config)#standby 5 prioirly 200

Dl-l3-2(config)#standby 5 preempt

Dl-l3-2(config)#standby 5 track interface f0/0 80

Dl-l3-2(config)#interface vlan 2

Dl-l3-2(config-if)#standby 2 ip 172.16.43.3

Dl-l3-2(config)#standby 2 prioirly 150

Dl-l3-2(config)#standby 2 preempt

Dl-l3-2(config)#standby 2 track interface f0/0 80

Dl-l3-2(config)#interface vlan 4

Dl-l3-2(config-if)#standby 4 ip 172.16.43.131

Dl-l3-2(config)#standby 4 prioirly 150

Dl-l3-2(config)#standby 4 preempt

Dl-l3-2(config)#standby 4 track interface f0/0 80


第5章 局域网的维护

5.1 软件系统

信息技术的发展,软件自身的安全也引起大量关注,软件安全主要分为系统软件、应用软件。

目前主要的系统软件主要有windows操作系统,netware操作系统、unix操作系统、linux操作系统。我们都知道系统通常有漏洞补丁,有些不法分子就是通过利用系统的漏洞进行攻击,盗窃信息,我们要经常关注系统开发公司的系统漏洞补丁,并打好漏洞补丁,定时对系统进行升级。个人建议购买正版软件使用。

应该软件包括很多种类,我们在下载安装是要从正当软件下载网站,或软件开发公司进行下载安装,不要到不明网站下载。另外,也要对应用软件进行升级,还要打软件补丁。

5.2 硬件系统

硬件顾名思义,就是我们能看的见,摸的着的,例如微软的系统是软件,那么思科的交换机就是硬件,硬件若果没有选好的话,后面也会引起很大的问题,例如硬盘的毁坏,数据库的丢失等等。选择好的硬件也将为网络安全起到一定的安全防范作用。

1.网卡安装与维护

有条线的网卡要根基网卡说明书调整条线,确保条线设置正确。

2.网络检查与维护

网络互连系统主要指网络的链接转发设备,包括交换机,路由器等。

(1)检测交换机故障。

交换机有几种状态,如果发生了故障,会有黄灯常亮,这个就需要检测,检测以后,才能确定是什么问题,然后进行抢修,这个就对硬件的选择时要非常的关键,尽量的选择一些国际大的,知名品牌产品来用,避免产生硬件的损害。黄灯的问题就是静电不能及时释放,干扰了数据信号

(2)检测路由故障

利用MIB变量浏览器,用他手机路由器的路由表,端口流量数据,计费数据,路由器CPU的温度、负载以及路由器的内存余量等数据。

(3)网络连线故障

网络连线是局域网的血管,没有他们,信息就无法流通。

3.建立防火墙

本次设计中使用的锐捷RG-WALL 50防火墙具有多线程代理方式,实时的状态监控功能,动态过滤技术,支持网桥模式和路由模式以及NAT模式等安全技术,有效防范了非安全访问和恶性攻击。

5.3 故障诊断和检查

物理故障主要就是指线断了,或者线头松动了等等,就是电源没有开启,也是属于物理故障,都需要一一的排查。.

逻辑故障,逻辑故障中最常见的情况就是配置错误,就是在配置,或者设置的过程中出现了故障,属于技术性的故障,这类故障一般不好排查,所以,要尽量避免出现这样的故障。

网络分层检测

诊断网络故障的过程应该沿着OSI七层模型从物理层开始向上进行。首先检查物理层,然后检查数据链路层,以此类推,设法确定通信失败的故障点,直到系统通讯正常为止[3]。

1.物理层及其诊断

物理层是基础的一层,主要就是看线头,线路的问题,有没有出现短路,或者断了等问题。确保各设备之间的连接线路四通的。

物理层的故障主要表现在设备的物理连接方式是否恰当;连接电缆是否正确;MODEM、CSU/DSU等设备的配置及操作是否正确。

2.数据链路层及其诊断

主要通过查看路由器的配置检查其封装,或者使用show命令查看相应接口的封装情况。


结束语

现在得计算机设备之间,都需要网络,系统,软件,硬件一起协同的服务,需要真正的连接进入互联网,才能真正的成为网络,本次通过对一个小企业的局域网的组建,使我的计算机的知识得到了提升和升华,对于我们不管是企业,还是个人来说,网络都时刻影响着我们的生活,学会动手解决网络组建方案,不仅能够得到同学,家人的赞许,以后进入社会,同样能够赢得公司的青睐,对于我们以后的职业生涯有着非常重要的意义,中小企业对这类人才的迫切需求,也注定了这类毕业生,会得到很好的就业机会。中小型企业Intranet建设不仅需要一个良好科学的规划设计、技术分析和实施维护过程,而且需要企业领导的重视和参与,这样才能将Intranet技术与中小型企业的计算机应用、相结合,使企业能够高效运行。

此文章浅谈了中小型局域网的组建和维护,也是我大学四年知识的一个积累。通过大四的毕业设计,使我的学习和实践能力又有了提高,相信这种这种提高会更好的展现在我以后工作,学习的舞台上。




                 谢词

经过几个月的紧张制作,毕业设计完成了,在这段日子里,我非常感谢我的指导老师,他非常的负责,给了我非常多的帮助,每当我有问题,需要问的时候,他都会第一时间给我回复,使我能够将遇到的问题及时的解决,导师的无微不至的关怀和帮助,在这里我要由衷的感谢。还有我还要感谢我的同学。在这段日子里,我的室友,都给了我极大的帮助,每当有问题自己解决不了的时候,大家都会一起来讨论,研究,一个团队的力量,就没有解决不了的问题。使我以后深刻的认识到要有团队精神。

此后,我会加倍努力的去研究,在熟练的基础上掌握更多的新型技术,来提高自己的开发水平。无论是在学校还是毕业,还是要不断的把知识慢慢加 深、巩固。 在论文即将完成之际,我的心情无法平静,从开始进入课题到论文的顺利完成,有多少 可敬的师长、同学、朋友给了我无言的帮助,在这里请接受我诚挚的谢意。